程序化指标公式
问答中心

通达信八方聚财指标公式

通达信指标 2023-01-26阅读量:1472

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。


N1:=3;N2:=5;N3:=8;N4:=13;

DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);

DEA:=EMA(DIFF,N2);

DRAWICON(DIFF>DEA,1,1);

DRAWICON(DIFF<DEA,1,2);

A1:=DIFF>DEA;

RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;

K:=SMA(RSV1,N1,1);

D:=SMA(K,N1,1);

DRAWICON(K>D,2,1);

DRAWICON(K<D,2,2);

A2:=K>D;

LC:=REF(CLOSE,1);

RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;

RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;

DRAWICON(RSI1>RSI2,3,1);

DRAWICON(RSI1<RSI2,3,2);

A3:=RSI1>RSI2;

RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;

LWR1:=SMA(RSV,N1,1);

LWR2:=SMA(LWR1,N1,1);

DRAWICON(LWR1>LWR2,4,1);

DRAWICON(LWR1<LWR2,4,2);

A4:=LWR1>LWR2;

BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;

DRAWICON(CLOSE>BBI,5,1);

DRAWICON(CLOSE<BBI,5,2);

A5:=CLOSE>BBI;

MTM:=CLOSE-REF(CLOSE,1);

MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);

MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);

DRAWICON(MMS>MMM,6,1);

DRAWICON(MMS<MMM,6,2);

A6:=MMS>MMM;

WJ:=(H+L+C)/3;

V1:=IF(H=L,1,H-MAX(O,C));

V2:=IF(H=L,1,MAX(C,O)-WJ);

V3:=IF(H=L,1,MIN(O,C)-L);

V4:=IF(H=L,1,WJ-MIN(C,O));

V5:=VOL/IF(H=L,4,H-L);

V6:=(V1*V5);

V7:=(V2*V5);

V8:=(V3*V5);

V9:=(V4*V5);

买盘:=(V9+V8);

卖盘:=(V6+V7);

买卖差:=买盘-卖盘;

DDX:=买卖差;

DX:=MA(买卖差,5)*20;

DDX1:=SMA(DX,3,1);

DDX2:=SMA(DDX1,3,1);

DDX3:=(5*DDX2+4*REF(DDX2,1)+3*REF(DDX2,2)+2*REF(DDX2,3)+REF(DDX2,4))/15;

DRAWICON(DDX1>DDX2,7,1);

DRAWICON(DDX1<DDX2,7,2);

A7:=DDX1>DDX2;

量:=V;

换手:=V/CAPITAL*100;

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

买盘1:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

卖盘1:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));

DLX:=(买盘1-(-卖盘1))/量*换手;

DLX1:=SUM(DLX,6);

DLX2:=MA(DLX1,5);

DRAWICON(DLX1>DLX2,8,1);

DRAWICON(DLX1<DLX2,8,2);

A8:=DLX1>DLX2;

买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6 =1

AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6 ,1)=0,COLORYELLOW;

持有:(A1 AND A2 AND A3 AND A4 AND A5 AND A6),COLORMAGENTA,LINETHICK2;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭