程序化指标公式
问答中心

通达信排兵布阵主图指标公式

通达信指标 2021-12-04阅读量:2501

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

C1G:=EMA(H,6);

Q1CG:=EMA(L,6);

F1L3:=LLV(C1G,6);

Q1FL3:=HHV(Q1CG,5);

命:=EMA(C,12);

命C:=EMA(命,12);

变异1:=命+命-命C;

变异线1:=EMA(变异1,6);

变异2:=变异1+变异1-变异线1;

变异线2:=EMA(变异2,6);

CG:=变异线1;

QCG:=变异线1;

多2:LLV(CG,2),COLORMAGENTA,LINETHICK1;

多3:LLV(CG,3),COLORMAGENTA,LINETHICK1;

多4:LLV(CG,4),COLORMAGENTA,LINETHICK1;

多5:LLV(CG,5),COLORMAGENTA,LINETHICK1;

多6:LLV(CG,6),COLORMAGENTA,LINETHICK1;

空2:HHV(CG,2),COLORGREEN,LINETHICK1;

空3:HHV(CG,3),COLORGREEN,LINETHICK1;

空4:HHV(CG,4),COLORGREEN,LINETHICK1;

空5:HHV(CG,5),COLORGREEN,LINETHICK1;

空6:HHV(CG,6),COLORGREEN,LINETHICK1;

DRAWKLINE(H,O,L,C);

A1:=(EMA(CLOSE,13)-EMA(CLOSE,34))*10;

RR:=EMA(A1,2)*1,COLORSTICK;

B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);

做多:=IF(A1>=B1,A1,B1),LINETHICK1,COLORRED;

做空:=IF(B1-A1,B1,A1),LINETHICK1,COLORGREEN;

STICKLINE(做多>做空,C,O,3,0)COLOR7F00FF;

STICKLINE(做多=做空,O,C,2.25,0)COLOR00FF7F;

F111:=ZIG(3,15);

F211:=IF((F111> REF(F111,1)),100,80);

T01:=CONST(LLVBARS(LOW,10));

T11HIGH:=CONST(REF(HIGH,T01));

CC1:=CONST(CURRBARSCOUNT);

T02:=CONST(BARSLAST((CURRBARSCOUNT >(CC1+T01)) AND (HIGH>T11HIGH)));

T12HIGH:=CONST(REF(HIGH,T02));

T03:=CONST(BARSLAST((CURRBARSCOUNT >(CC1+T02)) AND (HIGH>T12HIGH)));

T13HIGH:=CONST(REF(HIGH,T03));

洗:DRAWLINE(CURRBARSCOUNT=T03+1, T13HIGH, ISLASTBAR, T13HIGH, 1),DOTLINE,COLORFFFFFF;

AY:=REF(H,10)=HHV(H,2*10+1);

QYY:=BACKSET(AY,10+1);

CC:=FILTER(QYY,10) AND H=HHV(H,10+1);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD+1);

GDCS2:=CONST(DINGBUTS1);

压:=DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORFFFF00,LINETHICK1,DOTLINE;

DRAWTEXT_FIX(1,0.12,0.10,0,'注意: 没有规律,只有概率!没有绝对,只有应对!没有交易就没有伤害!'),COLORRED;

DRAWTEXT_FIX(1,0.12,0.15,0,'底下还有底,顶上还有顶 →右侧交易,追涨杀跌'),COLORGREEN;

DRAWTEXT_FIX(1,0.12,0.20,0,'耐心等待→细心辨别→决心出击→狠心纠错'),COLORGREEN;

AAC:=CLOSE/REF(CLOSE,1)>=1.04;

STICKLINE(AAC,H,L,0,0),COLOR00FFFF;

Z1A:=STRCAT(HYBLOCK,' ');

Z2A:=STRCAT(Z1A,FGBLOCK);

Z3A:=STRCAT(Z2A,DYBLOCK);

Z4A:=STRCAT(Z3A,' ');

DRAWTEXT_FIX(ISLASTBAR,0.25,0.98,0,STRCAT(Z4A,GNBLOCK)),COLORCYAN;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭