程序化指标公式
问答中心

通达信万有引力指标公式

通达信指标 2021-10-03阅读量:915

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。


高位:70.0;
中位:=40.0,COLOR8800FF,LINETHICK1;
VAR1:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3:=(SMA(VAR2,3,1)-18)*1.55;
VAR4:=SMA(VAR3,3,1);
VAR5:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR6:=SMA(VAR5,10,1);
VAR7:=(EMA(SMA(VAR6,8,1),34)-25)*2.6;
VAR8:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR9:=POW(MA(LOW,5),2)+MA(LOW,5);
VARA:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARB:=((VAR8-LLV(VAR9,64))/(HHV(VARA,64)-LLV(VAR9,64))*150+65-10)/2;
VARC:=SMA(VARB,3,1)*1.5-46;
VARD:=SMA(VARC,3,1);
VARE:=3*VARC-2*VARD;
VARF:=(VAR1+VAR2+VAR5)/3;
VAR10:=((VAR3+VAR3+VAR6+VARC)/4-15)*1.67;
VAR11:=((VAR4+VAR4+VAR7+VARD)/4-15)*1.67;
VAR12:=((VAR1+VAR5*2+VARF+VAR10+VAR11+VARB+VARC+VARD+VARE)/10-15)*1.67;
VAR13:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9;
VAR14:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92;
VAR15:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93;
VAR16:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94;
VAR17:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95;
VAR18:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91;
VAR19:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96;
VAR1A:=((VAR13*8+VAR14*8+VAR15*8+VAR16+VAR17+VAR18+VAR19)/28-0.1)*185;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(SMA(VAR1B,8,1)-8)*1.18;
VAR2N:=LLV(LOW,3)<=LLV(LOW,60);
VAR3N:= C>O AND (C/O>1.03 OR C>1.03*REF(C,1));
磁力点:IF(VAR2N AND VAR3N,30,0),COLOR999999,LINETHICK2;
零位:0.0,COLORBLUE,LINETHICK2;
引力1:(VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/9,COLORRED,LINETHICK2;
引力2:(VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/13,COLOR0066FF,LINETHICK2;
引力3:(VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/21,COLORYELLOW,LINETHICK2;
引力4:(VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/34,COLORGREEN,LINETHICK2;
引力5:(VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/55,COLORFFCC00,LINETHICK2;
引力:=(VAR3+VAR6+VAR1B*2)/4,COLOR999999,LINETHICK2;
MAC1:=EMA(引力1,3),COLOR666666;
ROC:=100*(CLOSE-REF(CLOSE,12))/REF(CLOSE,12);
地心线:=MA(ROC,3)+2,COLORFF00FF,LINETHICK2;
预设值:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
设置1:=SMA(预设值,5,1);
设值2:=SMA(设置1,5,1);
首峰线:3*设置1-2*设值2,COLORFF00FF,LINETHICK2;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭