程序化指标公式
问答中心

通达信涨跌有序主图指标公式

通达信指标 2019-09-14阅读量:355

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。

DRAWTEXT_FIX(C>0,0,0.9,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.85,0,EXTERNSTR(0,1)),COLORMAGENTA;
DRAWTEXT_FIX(1,0.045,0.9,0,EXTERNSTR(0,2)),COLORWHITE;
DRAWTEXT_FIX(1,0,1,0,EXTERNSTR(0,3)),COLORYELLOW;
QUSHI:=REF(EMA(C,10),1);
A1X:=(EMA(C,11)-QUSHI)/QUSHI*100;
CHIBI:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
CHIGU:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,CHIBI,QUSHI,1,0),COLOR9966CC;
STICKLINE(A1X<0,CHIGU,QUSHI,1,0),COLOR993333;
A1:=EMA(CLOSE,13)-EMA(CLOSE,55);
A2:=EMA((0.618*REF(A1,1)+0.382*A1),3);
STICKLINE(A1>=A2,H,L,0,0),COLOR00FFFF;
STICKLINE(A1>=A2,O,C,-1,0),COLOR0099DD;
STICKLINE(A1>=A2,O,C,2,0),COLOR00ABEE;
STICKLINE(A1>=A2,O,C,1,0),COLOR00DDFF;
STICKLINE(A1>=A2,O,C,0.1,0),COLOR00FFFF;
STICKLINE(A1<A2,H,L,0,0),COLOR00FF00;
STICKLINE(A1<A2,O,C,-1,0),COLOR009900;
STICKLINE(A1<A2,O,C,2,0),COLOR00AB00;
STICKLINE(A1<A2,O,C,1,0),COLOR00DD00;
STICKLINE(A1<A2,O,C,0.1,0),COLOR00FF00;
P1:=EMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5);
P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);
P3:=CROSS(P2,P1);
P4:=REF(P2,2)<REF(P2,1) AND P2<REF(P2,1);
P5:=COUNT(P3,7)>0 AND P4;
P6:=3*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1)-2*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1);
P7:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
MW:= EMA(P6,5);
NU:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
NU0:=SMA(NU,3,1);
NU00:=SMA(NU0,3,1);
NU10:=3*NU0-2*NU00;
NU1:=EMA(3*NU0-2*NU00,4);
NU2:=SMA(NU1,5,1);
NW:=MA(3*SMA(P7,6,1)-2*SMA(SMA(P7,5,1),5,1),2);
HW:=CROSS(NW,0) AND MW<56;
DP:=IF(P5 AND COUNT(P5,5)=1,1,0);
TP:=(HW AND DP) OR ((CROSS(IF(P6<3 AND NU2<5 AND NW<4,1,0),0.5))AND LLV(L,34)/HHV(H,144)<0.78),NODRAW;
STICKLINE(TP,H,L,0,0),COLOR0000FF;
STICKLINE(TP,O,C,-1,0),COLOR000099;
STICKLINE(TP,O,C,2,0),COLOR0000AB;
STICKLINE(TP,O,C,1,0),COLOR0000DD;
STICKLINE(TP,O,C,0.1,0),COLOR0000FF;
DRAWTEXT(TP,C*0.96,'TURNING POINT'),COLORRED;
A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3);
DD:REF(A,1),COLORBROWN;

版权声明

所有指标均为免费分享。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。

分享:

扫一扫在手机阅读、分享本文

程序化指标公众号

左边广告一

关闭

右边广告二

关闭